Fleetrun
Hecterra
NimBus
Другие приложения
Wialon для Android/iOS
Logistics
Wialon Local
Wialon Hosting
Distance Tag
WiaTag
Configurator
2204
Содержание
Как обновить Wialon Local с версии 1704 до 1804
  • upgrading_wialon_local

В этой инструкции описывается последовательность действий для обновления Wialon Local с версии 1704 до версии 1804.

Для корректного функционирования Wialon Local версий 1704, 1804 и 1904 необходим пакет Node.js 6.x . Поддержка старых версий Node.js, начиная с релиза 1804, прекращена.

Официальные репозитории Debian 8 и Debian 9 включают в себя пакеты более ранних версий. При установке из нашего дистрибутива Node.js необходимой версии устанавливается автоматически.

  1. Обновите Node.js до версии 6.x, если вы получили уведомление о том, что версия Node.js, используемая на вашем сервере, устарела. Для этого выполните следующие действия:
    • Войдите в терминал от имени главного пользователя (root) и выполните команды, указанные ниже.

      cd /home/wialon/wlocal/
      service wlocal stop
      ./adf_script stop
      apt-get install -y curl
      curl -sL https://deb.nodesource.com/setup_6.x | bash -
      apt-get install -y nodejs
      npm -g install forever
      npm install
      chown -R wialon:wialon /home/wialon/
      service wlocal restart
    • Проверьте доступность ваших сайтов после их перезапуска.

    Для обновления Node.js вы можете также обратиться в  службу технической поддержки. В этом случае укажите в письме данные для доступа в консоль сервера — SSH (IP, логин и пароль).

    Инструкция также расположена на  официальном сайте разработчика  Node.js.

  2. Установите версию Wialon Local 1804.



Если вы заметили ошибку в тексте, пожалуйста, выделите её и нажмите Ctrl+Enter.
Спасибо за ваш отзыв!
Сообщить об ошибке
Текст с ошибкой Комментарий
Максимум 500 символов